Módulo 01 ex 03

Módulo 01 ex 03

Home Fóruns Programação Básica Módulo 01 ex 03

Visualizando 7 respostas da discussão
  • Autor
    Posts
    • #80626
      Edna
      Participante

      programa
      {

      funcao inicio()
      {

      inteiro n1
      escreva(“Me diga um número: “)
      leia(n1)
      inteiro n = n1-1
      inteiro nu = n1+1

      escreva(“O antecessor de ” + n1 “é” + n)
      escreva(“O sucessor de ” + n1 “é” + nu)

      }
      }

      Neste meu exercício dapresenta um erro nesta linha -> escreva(“O antecessor de ” + n1 “é” + n)
      pedindo para que eu escreva um parenteses para resolver o problema ‘(‘

    • #80628
      Edna
      Participante

      programa
      {

      funcao inicio()
      {

      inteiro n1
      escreva(“Me diga um número: “)
      leia(n1)
      escreva(“O antecessor de” + n1 “é” + n1-1)
      escreva(“O sucessor é” + n1 “é” + n1+1)

      }
      }

      também fiz assim e apresenta o mesmo erro que esta linha do código -> escreva(“O antecessor de” + n1 “é” + n1-1) -> precisa de um ‘(‘ parenteses

    • #80646
      IcaroFilho
      Moderador

      Bom dia Edna,
      Antes de abrir um tópico no fórum, pesquise para saber se o mesmo já não foi aberto. No caso já existe um tópico criado sobre esta questão.
      isto evita com que o fórum fique “bagunçando” e dificulta a busca por resolução de questões por parte de outros alunos.

      Agora referente a sua questão.
      Na sua expressão falta uma concatenação.

      escreva(“O sucessor de ” + n1 “é” + nu) -> escreva(“O sucessor de ” + n1+“é” + nu)

    • #85470
      Edi Oliveira
      Participante

      programa
      {

      funcao inicio()
      {
      inteiro n1
      escreva(“Me diga um número: “)
      leia(n1)
      inteiro n = n1-1
      inteiro nu = n1+1
      escreva(“O antecessor de ” + n1 + “é” + n)
      escreva(“O sucessor de ” + n1 + “é” + nu)

      }
      }

      Console
      Me diga um número: 10
      O antecessor de 10é90 O sucessor de 10é11

      Como melhorar meu codigo ?

      • #85474
        IcaroFilho
        Moderador

        Boa noite Edi,
        Movi seu tópico pois o assunto já estava criado.
        Sempre que for criar algo, pesquise antes para saber se já não foi criado.

        no seu caso, pode utilizar espaços no final do texto(dentro das aspas) e usar quebra de linha

        escreva(“O antecessor de ” + n1 + “é” + n)
        escreva(“O sucessor de ” + n1 + “é” + nu)

        ficaria:

        escreva("O antecessor de " + n1 + " é " + n)
        escreva("\nO sucessor de " + n1 + " é " + nu)
    • #88318
      Douglas Silva
      Participante

      programa
      {

      funcao inicio()
      {
      inteiro n1, n2
      escreva(“Me diga um numero:” )
      leia(n1)
      inteiro n = n1-1
      inteiro nu = n1+1
      escreva(” o antecessor de ” + n1 + ” é o valor ” + (n1-1))

      escreva(“\n o sucessor de ” + n1 + ” é o valor ” + (n1+1))

      }
      }

      • #88395
        IcaroFilho
        Moderador

        Bom dia.
        Embora a resposta final esteja correta, você criou elementos e não utilizou.
        criou uma variável n2 nula e nunca utilizou no código.
        criou as variáveis n e nu e tbm nunca às utilizou.

        a forma mais compacta do codigo seria:

        inteiro n
        escreva(“Me diga um número: “)
        leia(n)
        escreva(“O antecessor de ” + n + “ é ” + ( n - 1 ) )
        escreva(“\nO sucessor de ” + n + “ é ” + ( n + 1 ) )

        e caso quisesse usar operadores separados:

        inteiro n, na, ns
        
        escreva(“Me diga um numero:” )
        leia(n)
        
        na = n - 1
        ns = n + 1
        
        escreva(” o antecessor de ” + n + ” é ” + na )
        escreva(“\n o sucessor de ” + n + ” é ” + ns )
    • #94542

      escreva(“O antecessor de ” + n1 + “é” n)`

      FALTOU APENAS UM + DEPOIS DO n1 que não tinha, e outra coisa, as vezes o portugal dá esses erros.

    • #94543

      programa
      {

      //exercicio 03
      funcao inicio()
      {
      inteiro n, ante, suce
      escreva(“Me diga um número: “)
      leia(n)
      suce = n + 1
      ante = n – 1
      escreva(“\nO antecessor de “+ n +” é o valor “+ ante + “\n”)
      escreva(“O Sucessor de “+ n +” é o valor “+ suce)
      `

      Fiz dessa forma, possível acho que está certo. Não sabia que dava para fazer dessa forma compacta.

    • #94729
      Tutor Davy
      Membro

      Matheus,

      Sua resolução do exercício está certa! Continue se dedicando assim e estará cada vez melhor.
      Se houver quaisquer dúvidas basta entrar em contato que lhe ajudaremos. 🖖

Visualizando 7 respostas da discussão
  • Você deve fazer login para responder a este tópico.
72486